Автор Тема: Сортировка в поле списка  (Прочитано 3034 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MeineVaterland

  • Коллежский регистратор
  • *
  • Сообщений: 6
  • Репутация: 0
Сортировка в поле списка
« : јРЩ 28, 2009, 08:20:25 am »
Добрый день,
помогите пожалуйста рассортировать по порядку элементы поля списка.
Имеется справочник "НужныеНазвания" с элементами в форме списка:

Код         Наименование

001         автор
002         абсолютно
003         барон
004         актриса
005         девушка

Есть общая форма "Основная форма" с элементами формы: поле списка (тип - "Список значений"), кнопка "Загрузить названия"
и процедура:

Процедура ДействияФормыЗагрузитьНазвания(Кнопка)
    ЭлементыФормы.ПолеСписка.Значение.Очистить();
    Справочник = Справочники.НужныеНазвания.Выбрать();
   Пока Справочник.Следующий() Цикл
       ЭлементыФормы.ПолеСписка.Значение.СортироватьПоЗначению(НаправлениеСортировки.Возр);
       Элементыформы.ПолеСписка.Значение.Добавить(Справочник.Наименование);
   КонецЦикла;
КонецПроцедуры

Процедура ПриЗакрытии()
   СохранитьЗначение("ПолеСписка", ЭлементыФормы.ПолеСписка.Значение);
КонецПроцедуры

Процедура ПриОткрытии()   
   ЭлементыФормы.ПолеСписка.Значение = ВосстановитьЗначение("ПолеСписка");
КонецПроцедуры

После нажатия на кнопку значения в поле списка сортируются следующим образом:
абсолютно
автор
актриса
барон
девушка

а мне нужно:
автор
девушка
барон
актирса
абсолютно

Можно ли установить свой порядок сортировки в зависимости от символа и позиции символа?